Jump to content
Language

agno

Member
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

1 Neutral

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. The trinket Shiver Venom Relic (https://www.wowhead.com/item=168905/shiver-venom-relic?bonus=4798:1487)should apply a debuff on the enemy that deals damage over time. It does apply a debuff, but it does way less damage, for example, the ilvl 440 trinket should do 2.985 damage per stack (X5 that ammount with the max stacks)l but instead it does 596 per stack, being because of this, the equivalent of a 380 ilvl trinket. The item ID is 168905, and the damage per stacks should be multiplied by 5 when fixed. Thanks
  2. Hello, I got the keystone conqueror achievement (complete a m15 in the time limit) and the Anima of death (tank essence) at rank 3. The rank 4 is supposedly bought for azerite residuum, but the vendor in boralus says that I don’t meet the requirements to buy the item (the reqs are r3 essence and keystone achievement), even though I do have what’s needed. It would be good if this was fixed so that the most dedicated players can get their r4 essence somewhere else apart from the etherside shop
  3. agno

    Nazjatar bugged loots

    while doing quests and farming in nazjatar I have come across a few items that don´t have loot inside (and they should). next to the names I have added the IDs -voidcaster´s supply bag (170195): drops a wide variety of materials, gems, etc. right now, it drops nothing -grimmy manapearl bracelet (170505): it should give 3 mana pearls, right now it gives none -ankoan supplies (170505): it´s the containter recived after completing the bonus reputation from the nazjatar faction waveblade ankoan. right now, the chest gives nothing at all and it should give gold, azerite, a mount and essences
  4. Yes, please fix this, I already lost the item used to summon one...
  5. Your character has been banned for speed cheating and invisible hacking in stormwind reported by 5 players
  6. agno

    drop rates

    The answer wasn’t right, the reputation is x100, the drop rate varies depending of the expansion (cata x2, wotlk x4 ish, pandaria x15, wod x15, aprox after a lot of testing) the world bosses have x1 to x3 drop rate and mincount is 0 while maxcount is 3 for most.
  7. Hello, most of the players have been coming back to the server because they heard about the upcoming update. Could anyone please give accurate information about when will it be updated? Also, will the loot tables from the world quests and mythics get updated? And will old players get any bonus for the new expansion like scaling for one of their chars to the 8.2 equivalent (this is just a question that is usually asked by players, I don’t really mind). Thanks for all of the hard work.
  8. Hello, I’m writing here because I submitted a ticket about this and I was recommended to submit it here, so here it goes: Hunters are able to tame mechanicals after consuming an item that allows them to, but after I consumed it and started looking for mechanicals, I noticed that the paint buckets in the raid “The siege of Ogrimmar” (from mists of pandaria) aren’t there, and those are required to build a mechanical scorpion that hunters are able to tame. I looked for the buckets but I couldn’t find them (I even used the buckets coordinates from Wowhead). So I suppose it’s a bug from this server that all of the buckets aren’t there and I would be really gratefull if you could fix that. Thanks for the help! Sadly after checking it for myself, the paint bucket was there, I was able to create the item=137658 which lets me summon the npc to tame (which should be neutral for me and friendly to everyone else), but the npc is friendly and I can´t tame it added a screenshot. I would be gratefull if I could get back the item (my char name is wolfblood) and if you could tell me when it´s fixed to check it. the npc ID is 107677 and the problem is it´s faction to summarize. Thanks again!
  9. There is one mechanical that is supposed to be walking arround highmountain, he patrols while stealthed across Mucksnout den and the fields of An’she And the hunter is supposed to track him down by looking for the oil puddles he leaves behind and then flare the location where he is. This mechanowolf is called Treble and it should be available in BFA, but he isn’t there (I waited in the entrance of a cave where he should have passed for 4 hours and nothing). Please fix this and also add the paint buckets in the raid “The siege of Ogrimmar” that are required to craft every Iron Juggernaut and then tame them. Thanks for the help
  10. Hello, I’m writing here because I submitted a ticket about this and I was recommended to submit it here, so here it goes: Hunters are able to tame mechanicals after consuming an item that allows them to, but after I consumed it and started looking for mechanicals, I noticed that the paint buckets in the raid “The siege of Ogrimmar” (from mists of pandaria) aren’t there, and those are required to build a mechanical scorpion that hunters are able to tame. I looked for the buckets but I couldn’t find them (I even used the buckets coordinates from Wowhead). So I suppose it’s a bug from this server that all of the buckets aren’t there and I would be really gratefull if you could fix that. Also there is another problem with the mechanical wolf from highmountain (Legion) which is a black wolf that should be tracked down (he’s invisible) but it isn’t there (I’m sure after I waited to intercept him in a part of his path). Thanks for the help!
  11. Hello, I’m writing here because I submitted a ticket about this and I was recommended to submit it here, so here it goes: Hunters are able to tame mechanicals after consuming an item that allows them to, but after I consumed it and started looking for mechanicals, I noticed that the paint buckets in the raid “The siege of Ogrimmar” (from mists of pandaria) aren’t there, and those are required to build a mechanical scorpion that hunters are able to tame. I looked for the buckets but I couldn’t find them (I even used the buckets coordinates from Wowhead). So I suppose it’s a bug from this server that all of the buckets aren’t there and I would be really gratefull if you could fix that. Thanks for the help!
×
×
  • Create New...